Core 2 から2.1 にあげたらこんなエラーが。

sc1231.PNG

はじめは、これか

https://blogs.msdn.microsoft.com/webdev/2018/05/07/asp-net-core-2-1-0-rc1-now-available/

と思って全部やってみましたが、かわらない。

エラーメッセージちゃんと読むの面倒だな・・と思いガチャガチャやってたら、うまくいかないのでちゃんと読んでみることに。(いつもそうしたほうがいいです)。

 

じゃ、まずシステムイベントログ読んでみる

sc1232.PNG

って、でてるじゃないか。

 

In your project file change any package reference to Microsoft.AspNetCore.All package to Microsoft.AspNetCore.App and add additional packages as needed to restore your required dependency graph

https://blogs.msdn.microsoft.com/webdev/2018/05/07/asp-net-core-2-1-0-rc1-now-available/

(この原文誰が書いたんだろ、スペルバンバン間違ってる)

 

ここに書いてあります(が、もちろん無視していました)。

 

やり方はここを一部参照にしました

https://docs.microsoft.com/ja-jp/aspnet/core/fundamentals/metapackage?view=aspnetcore-2.1

 

そして、さらに一山。バージョンが最新でなかったという落ち。

https://www.microsoft.com/net/download/windows

ここから最新版のSDKをインストールしておきましょ・・

 

無事動きました。

 

 

 

広告

コメントを残す

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください